Komfortabler Dateimanager mit vielen Funktionen

Installationstage

By Sven on 07.08.2006 - 11:16 in Fuhrpark

Die letzten Tage war ich größtenteils mit dem Zusammenbau des neuen Rechners und der Installation der Systeme beschäftigt. Der erste Start gestaltete sich aber etwas holprig, beim Booten wurde ein „CPU µCode Update Error“ angezeigt und nach der Statusmeldung des Intel Matrix Storage Manager Option ROM schien der Rechner zu hängen. Ein BIOS-Update half aber schnell weiter. Installiert war die Version 204, für den Core 2 Duo wird aber mindestens die Version 302 benötigt. Mittlerweile war auch schon die Version 405 verfügbar.

In solchen Augenblicken weiß man wieder einmal ein Diskettenlaufwerk zu schätzen, das BIOS-Update funktionierte über das im BIOS eingebaute Aktualisierungsprogramm problemlos. Beim nächsten Start war dann auch die Fehlermeldung weg und das Einrichten der beiden RAID-Systeme ging schnell vonstatten. Für Betriebssysteme und Auslagerungsdatei habe ich ein RAID-0 mit 70 GB eingerichtet. Die übrigen 200 GB werden in einem RAID-1 gespiegelt, hier liegen dann alle gemeinsam genutzten Daten und Entwicklungstools.

Früher musste immer darauf achten, dass der Startsektor des Betriebssystems innerhalb der ersten 1024 Zylinder lag, ansonsten ließ sich Windows nicht booten. Das beschränkte natürlich die Größe der ersten zwei Partitionen auf insgesamt 8 GB, sofern man drei verschiedene Systeme nebeneinander installieren wollte. Mit Windows XP und Vista ist das nun alles Geschichte, dementsprechend großzügig habe ich auch die Partitionen eingerichtet. Windows XP bekam 10 GB, Windows XP x64 etwas mehr (15 GB) und für Vista sollten 20 GB mehr als ausreichend sein. Zur Installation jedes Systems wird die jeweilige Partition aktiviert, damit installieren sich alle Systeme als Laufwerk C. Anschließend wird dann die x64-Partition aktiviert und alle Systeme können über das NTLDR-Menü gestartet werden.

Das Einrichten der gewohnten Umgebung nimmt dann natürlich die meiste Zeit ein, zumal dies gleich zweimal (Windows XP und Windows XP x64) erfolgen muss. Bisher habe ich x64 nur zum Testen und Debuggen verwendet, nun möchte ich aber auch einmal probieren, wie sich x64 im täglichen Einsatz schlägt. Die ersten negativen Erfahrungen habe ich gleich gemacht. Für meinen Canon LBP3000 gibt es noch keine 64-Bit-Druckertreiber und meine DOS-Fakturierung will aufgrund der fehlenden 16-Bit-Unterstützung auch nicht mehr funktionieren. Temporäre Abhilfe schafft hier vorerst ein Windows XP in einer VM.

Der von mir seit langem genutzte MailWasher Pro gab beim Eintreffen neuer eMails nur ein schnödes „Beep“ von sich, anstatt den Systemklang für neue Nachrichten abzuspielen. Beim Versuch, den Klang zu konfigurieren, gab es die Meldung, dass sich die Datei mmdriver.inf nicht im System32-Verzeichnis befindet. Es gab sie dort zwar, aber ein Kopieren der Datei in das SysWOW64-Verzeichnis (das System32-Verzeichnis für 32-Bit-Programme) beseitigte die Fehlermeldung. Trotzdem spielte MailWasher noch keinen Sound ab, anscheinend konnte er die Klangdatei im Media-Verzeichnis trotz richtig eingetragenem Namen nicht finden. Ein etwas unorthodoxes Ändern des Startverzeichnisses in der Programmverknüpfung von MailWasher auf „C:\Windows\Media“ brachte Abhilfe.

Sehr unschön ist der Umstand, dass der ICH8-Chipsatz keine IDE-Schnittstellen mehr enthält. Zwar ist auf dem Board noch ein SATA/PATA-Controller von JMicron, über den sich noch zwei ATAPI-Geräte einbinden lassen. Leider kann aber der oakcdrom.sys-Treiber darüber angebundene Geräte nicht mehr erkennen und benutzen. Somit ist meine für’s Imagen verwendete DOS-Boot-CD nur noch eingeschränkt verwendbar. Zwar klappt das Booten, aber der Zugriff auf die auf der CD vorhandenen Tools ist nicht möglich. Das Booten über einen USB-Stick schlug bei einem ersten Test noch fehl. Vorerst muss ich also über die CD booten und dann das Imageprogramm vom USB-Stick starten.

Ansonsten überwiegen aber bisher die Vorteile und vor allem überzeugt der enorme Performance-Schub. Mehr zu diesem und ein paar Zahlen aus der Praxis gibt es im Laufe der Woche.

Es gibt 4 Kommentare zu diesem Beitrag

Trackback URL | RSS-Feed für Kommentare

  1. Eric sagt:

    Um von aussen auf einen Rechner zuzugreifen nutze ich nur noch PEBuilder : http://www.nu2.nu/pebuilder/
    Auch prima um Viren, Trojaner, etc zu entfernen da besagte Programme keine Schutzmöglichkeiten haben. Auch der SC ist natürlich mit an Bord 🙂

  2. Sven sagt:

    Ich fürchte, da läuft mein Drive Image nicht drauf. Bei mir ist immer noch die reine DOS-Version im Einsatz.

  3. Dosi sagt:

    Das Problem mit dem CD-Laufwerk scheint Kreise zu ziehen. Ist das der entgültige Abschied von DOS? Dennoch:
    – ich weiß nicht, ob eine Bootdiskette von FreeDOS das Laufwerk anspricht. Probieren?
    – Könnte z.B. ein Promise Kontroller das Laufwerk für DOS ansprechbar machen?
    – Egal: wenn ich das DOS-Drive Image starte – Boot von DOS-Disk ohne CD Treiber -, so zeigt es mir in der Laufwerksliste das Laufwerk als „\\.\Pqcd0 blabla“ und das Image ist voll lesbar und wiederherstellbar. Witzig! So viele Jahre Arbeiten mit Drive Image und ich muss erst jetzt feststellen, das es eigentlich gar keinen DOS Treiber für das CD Laufwerk braucht!
    Wie ist es bei Dir?

  4. Sven sagt:

    Hatte ganz vergessen zu berichten, dass sich der DOS-Zugriff auf das CD-Laufwerk mit einer Boot-CD im ElTorito-Format lösen lässt. Der Ausgangspunkt ist ein Emulator, auf diesens setzt dann der ElTorito-Treiber auf.

    An einen Promise-Adapter hatte ich auch schon gedacht, allerdings war ich mir nicht mehr sicher, ob sich der Ultra DMA 100/133 quasi wie eine normale IDE-Schnittstelle verhält und so vom OAK-CDROM-Treiber angesprochen werden kann.

    Das Problem mit dem DOS-DriveImage war, dass es sich nicht direkt von CD starten ließ. Der Rechner kann zwar von CD booten, das Laufwerk und damit alle Programme auf der CD können aber nicht angesprochen werden. Man sieht nur das emulierte Laufwerk A mit den Systemdateien. Mit der ElTorito-CD ist das aber nun Geschichte, alles läuft wie vorher.

    Die aktuellen Linux-Distributionen können übrigens auch nicht auf den JMicron-Controller zugreifen, damit lässt sich Linux nicht installieren. Im Kernel 2.6.18 soll das Problem gelöst sein. Einfach mal nach „linux jmicron“ googeln.

Top