Komfortabler Dateimanager mit vielen Funktionen

Datenverlust beim Kopieren (2)

By Sven on 04.10.2007 - 11:41 in Windows Vista

Die ganze Sache hat mir keine Ruhe gelassen, daher habe ich gestern noch weitere Tests durchgeführt. Bisher hatte ich immer nur auf meinen Dateiserver kopiert, wenn auch von zwei verschiedenen Rechnern. Um auszuschließen, dass das Problem mit dem Dateiserver zusammenhängt, habe ich die Testdaten nun über Kreuz kopiert, d.h. vom Vista des einen Rechners auf ein XP des anderen sowie vom Vista des anderen auf das XP des einen Rechners. Erstaunlicherweise wurden die Daten hierbei ohne Fehler kopiert. Auch die Kopien auf mein Notebook waren fehlerfrei.

Damit scheint festzustehen, dass der Datenverlust beim Kopieren kein allgemeines Problem von Vista ist, sondern mit der Konfiguration meines Dateiservers zu tun haben muss. Auf dem Server läuft ein RAID-1, welches an einem zusätzlichen SIL3112-Controller (Silicon Image) angeschlossen ist. Probleme gab es damit bisher nicht, auch das RAID-Statusprogram und die Ereignisanzeige zeigen keine Fehler an. Trotzdem habe ich das RAID aufgelöst, die beiden Festplatten wieder an den Onboard-RAID-Controller (VIA VT8237) angeschlossen und erneut ein RAID-1 erstellt.

Erneute Tests mit dem nun neuen RAID-1 funktionierten wiederum fehlerfrei. Das heißt also, dass die Kopierfehler irgendetwas mit der alten RAID-Konfiguration zu tun haben müssen. Warum sie dann aber bei gesetztem “CopyFileBufferedSynchronousIo” nicht auftraten, dafür habe ich keine Erklärung. Den Eintrag “CopyFileBufferedSynchronousIo” werde ich aber trotzdem aktiviert lassen, da damit die Datentransferrate beim Kopieren über das Netzwerk spürbar angehoben wird.

Es gibt 4 Kommentare zu diesem Beitrag

Trackback URL | RSS-Feed für Kommentare

  1. HabeIch sagt:

    ROFL
    Und darum so einen Wind…
    Aber klar zuerst ist immer Windows schuld ^^

  2. Stefan sagt:

    Auf jeden Fall vielen Dank für die Info
    und die ausführliche Beschreibung (und für die “Lösung” !!! )

  3. Hornen sagt:

    @ Habelch

    Bei mir läuft kein RAID und ich hatte das selbe Problem welches nun durch den Registrywert + Hotfix soweit behoben scheint.

  4. Luke sagt:

    Puh, das ist beruhigend. Und andererseits erschreckend. Wie kann man ein RAID1-Produkt verkaufen welches Daten matscht. Erinnert an:
    RAID 0 has redundancy, but the other way round: If some of the disks non-fail, that non-failure can still be worked around by another disk failing. Indeed, it has very high reverse redundancy: Even if all but 1 disks non-fail, the one failure still ensures complete failure of the array. The more disks you use, the better you are protected against non-failure.

Top