Komfortabler Dateimanager mit vielen Funktionen

Ausgeraidet

By Sven on 11.04.2007 - 13:31 in Windows Vista

Beim Zusammenbau meines neuen Rechners hatte ich geschrieben, dass mich das Konzept des Matrix-RAID voll überzeugt hat. Mit nur zwei Festplatten lassen sich gleichzeitig ein RAID-0 und ein RAID-1 betreiben. Somit hat man genügend Dampf für das Betriebssystem und ausreichend Sicherheit für die Daten.

Bis Anfang März lief auch alles recht problemlos. Das RAID-1 musste zwar zweimal synchronisiert werden, weil sich das System jeweils nur über einen harten Reset neustarten ließ. Die Synchronisierung läuft aber komplett unter Windows im Hintergrund, so dass man nicht weiter aufgehalten wird.

In den letzten Wochen musste ich aber feststellen, dass das Matrix-RAID in Kombination mit Vista ein paar gemeine Überraschungen bereithält. Nach einem Neustart meldete das Intel Raid-BIOS plöztlich für die erste Festplatte “Error occured”. Damit war das RAID-0 zerstört und das RAID-1 auf “Degreaded” gesetzt. Aber gut, Festplatten können ausfallen. Also fix eine neue Festplatte eingebaut und diese als Ziel für die nötige Synchronisierung vom RAID-1 festgelegt. Das RAID-0 musste neu erstellt werden. Theoretisch war das auch kein großes Problem, da für alle Systeme aktuelle Sicherungen vorlagen. Dummerweise hatte ich diese aber auf einer Partition im RAID-1 und TrueImage wollte die Partition solange nicht anzeigen, bis das RAID-1 wieder synchronisiert war. Ohne Image aber keine Synchronisiation, da diese ja wie oben beschrieben nur in einem laufenden Windows durchgeführt werden kann. Irgendwie habe ich es dann doch noch geschafft. Die Aktion dauerte einen ganzen Tag, aber beim ersten Mal braucht eben alles etwas länger. Daten gingen keine verloren. Zukünftige Sicherungen wollte ich nun auf eine andere Festplatte erstellen.

Blöd ist nur, wenn das gleiche am nächsten Tag erneut passiert. Durch die gesammelten Erfahrungen war ich aber nun etwas abgehärteter. Statt dem Kauf einer weiteren neuen Festplatte habe ich die RAID-Informationen auf der “defekten” Festplatte zurückgesetzt und das RAID wieder frisch initialisiert. Nach dem Zurückspielen der Systeme wurde das RAID-1 unter Windows neu synchronisiert. Die morgendlichen Rechnerstarts in den nächsten Wochen habe ich skeptisch verfolgt, aber es ging alles gut.

Letzte Woche hat der RAID-Teufel wieder zugeschlagen. Einen Tag vor dem Osterurlaub meldete die Intel Storage Manager Console pötzlich mitten im Betrieb, dass beim Schreiben auf RAID-0 Probleme aufgetreten sind. In der Console war wieder die Festplatte 1 als defekt markiert, aber das System lief noch rund. Also habe ich kurzentschlossen alle Daten aus dem RAID-1 auf eine zweite Festplatte kopiert und mir vorgenommen, über die Zukunft des Matrix-RAIDs diese Woche noch einmal gründlich nachzudenken.

Lange Zeit zum Nachdenken gab es aber nicht. Gestern nachmittag brauchte das System wieder viel Zeit, um zwischen zwei Anwendungen hin- und herzuschalten. Zudem glühte die Festplattenleuchte fast ununterbrochen. Nachdem sich der Rechner wieder erholt hatte, tauchte der schon bekannte Hinweis auf ein RAID-0-Problem auf. Auch in der Ereignisanzeige fand sich wieder die Fehlermeldung

Das Gerät \Device\Ide\iaStor0 hat innerhalb der Fehlerwartezeit nicht geantwortet.

Nach einer intensiven Google-Suche ließ sich erkennen, dass ich mit diesem Problem nicht allein dastehe. Es gibt eine Vielzahl von Diskussionen über dieses Problem, aber keine eindeutige Lösung. Intel kann diese Probleme im Labor nicht nachvollziehen und Asus sagt, dem Board wurde bisher noch kein Vista-Kompatibilitätsstempel aufgedrückt. Zwar hat Intel einen Tip bereitgestellt, der mögliche Seiteneffekte einer neuen Installationsroutine von Vista beseitigen soll. Helfen tut dies aber leider auch nicht richtig.

Damit ist nun der Moment gekommen, in dem ich mich vom Matrix-RAID verabschiede. Es macht einfach keinen Spaß mehr, ständig Images zurückspielen zu müssen. Zudem kostet es trotz der mittlerweile erlangten Routine auch immer wieder wertvolle Zeit. Ab sofort laufen auf dem Rechner wieder zwei ganz normale Festplatten im AHCI-Modus und die Daten werden wie früher manuell gesichert.

Es gibt 7 Kommentare zu diesem Beitrag

Trackback URL | RSS-Feed für Kommentare

  1. hanni sagt:

    das ist natürlich ärgerlich! hoffe konntest dich trotzdem ein bisschen erholen sven 🙂

  2. CoolWater sagt:

    Ich kann dein Leid nachvollziehen… Hatte meinen File-Server auch im Raid-Betrieb (Mirror) laufen und das 24-Stunden am Tag. Dabei habe ich des öfteren erlebt, dass mich Windows beim Anschalten des Monitors mit einem Bluescreen überraschte. Grund war, dass eine der beiden Platten nicht wieder aus dem Ruhestand aufgewacht ist (obwohl dieser deaktiviert war).

    Mittlerweile laufen die Platten nicht mehr als Raid und seither hab ich auch keine Probleme/Bluescreens mehr. Die automatisierte TrueImage-Sicherung funktioniert auch wunderbar. Was will ich also mehr 😉

  3. Sven sagt:

    Mit dem RAID-1 auf meinem Server hatte ich in den letzten Jahren überhaupt keine Probleme. Allerdings läuft es nur von morgens bis abends, in der Nacht wird der Rechner heruntergefahren.

  4. Kay sagt:

    Herzliches Beileid!
    Ich habe vor zwei Jahren auch (aus Lärmgründen) ausgeraided…
    Beeinflusst das fehlende Raid eigentlich die SpeedCommander Kompilierzeit?

  5. Sven sagt:

    Dürfte keinen großen Einfluss haben. Quelltexte und Tools lagen auf dem RAID-1, während sich das Temp-Verzeichnis auf einer normalen SATA-Platte befindet.

  6. Wolfgang Graßmann sagt:

    ich habe einen DELL XPS420.Und so extrem sind meine Probleme nicht, nur daß das Tool Intel Matrix Storage Console nicht normal funktionier, sondern hängt und nahezu unbedienbar ist

  7. Sven sagt:

    Diesen Effekt kenne ich auch. Bei mir trat er aber immer nur auf, wenn eine neue Platte angehangen wurde bzw. das RAID neu initialisiert werden musste. In diesen Fällen braucht die Storage Console unheimlich viel Zeit und man selbst viel Geduld (und Kaffee).

Top